Platform performance issues

Minor incident Web & Mobile Login
2026-08-19 13:32 PDT · 3 hours, 30 minutes

Updates

Resolved

We have resolved this incident and will be putting additional monitoring and mitigations in place to improve our platform stability during periods of increased network traffic.

August 19, 2026 · 17:00 PDT
Monitoring

We believe we have mitigated a network issue that was affecting platform performance but the team is continuing to monitor the situation.

August 19, 2026 · 15:48 PDT
Issue

Engineering teams are investigating platform performance issues

August 19, 2026 · 13:32 PDT

← Back