Peregrine platform having issues

Major incident Web & Mobile Login Data ingestion Vendor API
2026-07-20 17:24 PDT · 1 hour, 36 minutes, 1 second

Updates

Resolved

This situation has been resolved

July 20, 2026 · 18:57 PDT
Monitoring

We have identified the issue. The platform has returned to a stable state. Teams are monitoring the situation

July 20, 2026 · 18:24 PDT
Issue

Peregrine engineering teams are aware of issues with the platform causing instability in login and searches. The team is investigating

July 20, 2026 · 17:24 PDT

← Back