Peregrine is experiencing issues affecting platform loading

Major incident Web & Mobile Login
2026-04-30 02:55 PDT · 26 minutes

Updates

Resolved

The immediate issue is resolved. The platform is functional now. Engineering teams are investigating the root cause

April 30, 2026 · 03:19 PDT
Investigating

Engineering teams are investigating

April 30, 2026 · 02:55 PDT

← Back