Peregrine website is down

Major incident Web & Mobile Login
2026-03-26 11:14 PDT · 46 minutes

Updates

Resolved

The outage was caused by an issue during a routine deployment, which has since been resolved.

March 26, 2026 · 11:59 PDT
Monitoring

We are seeing gradual recovery in the platform. Team is actively resolving issues and monitoring.

March 26, 2026 · 11:49 PDT
Issue

Peregrine website is down. The team is currently investigating.

March 26, 2026 · 11:14 PDT

← Back