Peregrine Platform Service Degradation
Major incident
Web & Mobile
Data ingestion
2025-05-22 11:00 PDT
· 4 hours, 35 minutes
Updates
Monitoring
May 22, 2025 · 15:00 PDT
Peregrine web and mobile have recovered.
Real-time data ingestion platforms are recovering. Users may encounter delays in data ingestion.
Investigating
May 22, 2025 · 12:47 PDT
We are currently experiencing degraded performance across the Peregrine web, mobile and data ingestion platforms. Users may encounter slower response times, intermittent connectivity issues, or reduced functionality when accessing search features and internal API services.
← Back
Status