Platform is experiencing intermittent login issue

Minor incident Web & Mobile Login
2025-04-28 18:19 PDT · 49 minutes

Updates

Resolved

This issue has been resolved. The engineering team is adding new resources to the platform infrastructure and will continue to monitor the situation.

April 28, 2025 · 19:07 PDT
Issue

We are currently experiencing intermittent issues across the platform. Our team is actively working to resolve the problem as quickly as possible.

April 28, 2025 · 18:19 PDT

← Back