Platform platform outage

Major incident Web & Mobile Login Data ingestion Vendor API
2025-03-24 09:59 PDT · 1 hour, 31 minutes

Updates

Resolved

This issue has been resolved. Platform functionality is restored. New data ingestion is being slowly re-enabled. Engineering teams continue to closely monitor the situation.

March 24, 2025 · 12:53 PDT
Monitoring

We will continue to monitor the situation as data ingestion is gradually re-enabled.

March 24, 2025 · 12:26 PDT
De-escalate

Login is restored and search is working now.

Data ingestion will continue to be disabled for a while longer while we investigate the root causes of this incident.

March 24, 2025 · 12:14 PDT
Update

Engineering teams continue to troubleshoot. We have identified the root cause and working on the mitigation. As a precaution all users have been logged out. We apologize if this caused you any inconvenience.

March 24, 2025 · 11:07 PDT
Update

Engineering teams are continuing to address the issue at this time. New data ingestion will be paused to aid in troubleshooting.

March 24, 2025 · 10:40 PDT
Escalate

We have identified an issue with database resource usage. Login is only intermittently available while we triage this issue. More updates coming soon.

March 24, 2025 · 10:11 PDT
De-escalate

Login has been restored. We continue to evaluate the on-going situation

March 24, 2025 · 10:06 PDT
Issue

We have detected issues with login to the Peregrine platform and we are currently investigating, we’ll update you shortly.

March 24, 2025 · 09:59 PDT

← Back